MACROMEDIA FLASH 8 SESSION 4

SESSION 4: FX ANIMATION

1. MOTION GUIDE

TUTORIAL GERAKAN MELINGKAR

Animasi jalur atau Motion Guide Tween adalah objek yang bergerak mengikuti
suatu jalur tertentu yang telah ditentukan pada layer guide.

Jadi animasi jalur menggunakan 2 buah layer, yaitu layer untuk objek dan animasi
(Layer 1) dan layer untuk guide (Guide: Layer 1). Garis guide bisa dibuat
menggunakan Pen tool, Line tool, Pencil tool, Rectangle tool, atau Oval tool.

Pada latihan ini, kita akan membuat lingkaran yang bergerak berkeliling mengikuti

garis orbit.
1. Klik Oval tool, lalu gambar lingkaran kecil di layar. Ubah menjadi simbol:
Graphic.

2. Klik menu Insert > Motion Guide, akan muncul layer baru di atas Layer 1
dengan nama Guide: Layer 1.

3. Pindah ke layer Guide: Layer 1, lalu gambar lingkaran besar menggunakan Oval
tool, aturlah bidang tanpa warna dan pinggir hitam.
4. Klik Eraser tool untuk memotong bagian bawah lingkaran.

L N o ‘\H_‘___q =

Hasil pemotongan Memotong dengan Eraser
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5. Setelah garis terbentuk, klik frame 30 lalu Insert Frame.

6. Pindahkan ke layer 1, lalu pindahkan lingkaran kecil ke awal garis. Ketepatan
letak lingkaran pada awal garis ditandai dengan cincin saat proses pemindahan.
(Apabila cincin tidak terlihat, coba klik menu View > Snap to Objects).

.
~» —

7. Klik pada frame 30 lalu klik Insert Keyframe.
8. Masih di frame 30, pindahkan lingkaran kecil ke akhir garis. Perhatikan ketepatan
letak lingkaran pada akhir garis ditandai dengan cincin saat proses pemindahan.

9. Kilik frame 1 untuk kembali ke frame 1, lalu pada Properties pilih bagian
Tween: Motion. Jalankan animasi.

ANIMASI MOTION GUIDE MENGGUNAKAN HURUF

Dalam pembahasan kita kali ini, kita akan membahas teknik animasi menggunakan
motion guide. Dimana nantinya kita akan membuat tulisan berjalan berkelok — kelok.
Untuk lebih lanjut bagaimana langkah — langkah membuat animasi motion guide
menggunakan huruf berikuta adalah langkah — langkah nya :

1. Buatlah Movie baru dengan Framerate nya 25 fps dalam aplikasi
Macromedia Flash 8.
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2. Pada layerl ubah namanya menjadi Objek A, pilih Teks Tool [A Ketik A
pada jendela movie lalu pada jendela properties pilih opsi sebagai berikut :

a. Font= Arial , b. Font Size= 30, c. Teks Fill = #000000

4% Properties  Filkers | Param
Ab

IStatic Text A Inrial j ‘30 ’j@ B 7 =E=== 19 5,
HE\-' ] | Al INDrmaI j I.C\.nti-alias for readability j
v auta kern

W;| 37.5 x:| 175.3

A | | @ o E
(= I Target:l vl

H;| 24,2 \-';I 205.5

Pengaturan Teks pada jendela properties

3. Klik kanan pada objek A pilih Convert To Symbol, Dalam jendela Convert
To Symbol pilih opsi sebagai berikut :
a. Name =A

b. Type
c. Registration

Movie Clip
Pilih titik Pinggir kiri atas

]

Convert to Symbol

Mame: | &
Type: (¥ Mavie clip Regiskration: EEE
() Butkon
) Graphic

Kotak dialog Convert To Symbol dengan name nya A

4. Tambah Layer baru ubah nama nya menjadi Objek O, pilih Teks

5. Tool [A ketik O pada jendela movie lalu pada jendela properties
pilih seperti gambarl.

Klik kanan pada objek o pilih Convert To Symbol, Dalam jendela Convert
To Symbol pilih opsi sebagai berikut :

a. Name =0

b. Type
c. Registration

Movie Clip
Pilih titik pinggir Kiri atas
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Convert to Symbaol

SESSION 4

Marme: |:||

Type: (%) Movie dip
{:} Button

() Graphic

Registration: #80

oono

Kotak dialog Convert To Symbol dengan name nya o

7. Ulangi langkah No.4 dan 6 ganti teks dengan 8, o, T dan ubah Layer nya.
8. Pada jendela Timeline pilih Add Motion Guide.

- Objek .
Obisk O .
[ obisk & .

[[@ obisk o

hiek A
Sy

a
|
]
|
i

4 mla) Bl [zofs [oos o] ]

Add Motion Guide pada jendela Timeline

9. Atur Posis layer dengan cara di Drag menjadi seperti gambar dibawabh ini :

&40

- Guide: &,
[ Objek T s+ 0
[ cbjekn + « O
[ Obijek 3 s+ 0
[ objek o + + N
[ objek & s o+ [
B dhE] i

=

Posisi layer sebelum di atur

5 Guide: 0. + « [0

[ objek T s .

4]

| ] B

Posisi layer sesudah diatur

8. Pada Layer Motion Guide pilih Pen Tool ﬁ , dan pada Option pilih
smoot. Buatlah garis melengkung dalam jendela Movie, seperti gambar

dibawah ini.

Cplions
a s.

I-| Skraighten

.Kotak Option pada
jendela Tools

Srmooth

a4 Ink
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garis melengkung menggunakan Pen Tool.

9. Pada Framel20 di Layer A, 8, o, T, o Klik kanan pilih Insert Keyframe,
sedangkan pada Layer Motion Guide di Frame120 Klik kanan pilih Insert
Frame.

10. Pada Layer A,0,8,0,T klik kanan pilh Create Motion Tween.

11.Di framel pada objek A,o0, 8, o, T atur posisi objek nya tepat di ujung

L1

depan garis, dengan menggunakan Free Transform Tool seperti

gambar dibawah ini :

Posisi obiek A,0,8,02, T pada Framel
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12.Pada Layer A, 8, 02 di Framel pilih Snap To Objects ﬂ pada jendela
properties chek list pada Orient to Path.

£ ™ properties  Filkers | Parameters

| II Frame Tween: IMDtiu:un j v scale
I =Frame Label= Ease: II:I j Edit. .. |

Label tvpe: kate: I.ﬁ.ut-:u j IEI kimes
IName j kIF rient ko path W Sync W Snap

Orient to path pada jendela properties.

13.Pada Layer o dan T di Framel pilih Snap To Objets ﬂ pada jendela
properties chek list pada Orient to path, Sync, Snap.
14.Di Framel20 pada objek A,o0, 8, 02, T atur posisi nya tepat di ujung

I1

belakang garis, dengan menggunakan Free Transform Tool seperti

gambar di bawah ini.

Posisi objek A,0,8,0,T pada Frame120

15.Animasi siap dijalankan dengan menekan tombol Ctrl + Enter.

2. MASKING

Animasi Masking adalah animasi objek yang menutupi objek lain, sehingga objek
yang menutupi terlihat transparan.

Pada latihan ini, kita akan membuat objek tulisan yang akan terlihat apabila
tertutupi oleh objek kotak segi panjang. Kemudian kita akan menambil suara yang
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sudah tersedia dalam Flash di Common Libraries Sounds-nya, dan
menyisipkannya dalam animasi kita. Penggunaan suara dapat menambah daya tarik
pada animasi.

1. Klik Text tool, lalu tulislah ‘MASKING’ di layar.

2. Klik pada frame 40, lalu klik kanan dan pilih Insert Frame.

3. Klik menu Insert > Layer (atau klik pada tanda plus di panel Timeline) untuk
membuat layer baru. Sekarang kita punya 2 buah layer, yaitu Layer 1 dan Layer
2.

TS o]

Add layer

4. Klik Layer 2 untuk berpindah layer, lalu klik Rectangle tool untuk gambar segi
panjang diatas teks. Lebar dan panjangnya disesuaikan dengan ukuran teks.

MASKING

Kotak segi panjang di atas teks

5. Pilih kotak segi panjang lalu ubah menjadi simbol: Graphic.

6. Klik pada frame 20, lalu masukkan Keyframe. Lakukan hal yang sama pada
layer 40.

7. Klik frame 20 lagi untuk kembali ke frame 20, lalu pindahkan kotak ke bawah
teks.

MASKING

Kotak segi panjang di bawah teks

8. Klik pada frame 1, lalu pada Properties pilih bagian Tween: Motion. Lakukan
hal yang sama pada frame 20.
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9. Kemudian, klik kanan pada Layer 2, lalu pilih Mask.

" EHE'.EI|1 :
| I Loyor 2 i :

L 1
o ko Lock, Others -
Hide Cthers
Insert Layer
4t ] : 1]

Delete Laver
é Scene Guide
&dd Mation Guide

Mask.

Pemberian efek Mask pada Layer 2

10. Terakhir, tambahkan suara. Klik menu Window = Common Libraries >
Sounds, akan muncul pilihan suara.

11. Setelah kita memberi efek Mask pada layer, biasanya layer-layer tersebut akan
terkunci (ditandai dengan gembok pada layer). Klik pada tanda gembok untuk
unlock supaya kita dapat mengedit.

£ %5 ] (]
Unlock layer

3. FLASH HACKING

1. Merubah Format SWF Ke FLA menggunakan SWF Decompiler

Setelah kita memahami dasar —dasar penggunaan SWF Decompiler diatas, kini kita
akan mempelajari bagaimana mengconvert Format SWF ke Format FLA.

Yang harus pertama anda lakukan adalah mempunyai Format SWF untuk
mengconvert ke Format FLA berikut langkah —langkah nya :

1. Buka Program SWF Decompiler.

2 Dalam Explorer buka Format SWF yang ingin dijadikan Format FLA.
( Dalam Latihan kali ini kita menggunakan Be you SWF yang disertakan dalam
CD latihan ).

3. Dalam Menu Utama pilih File > Export FLA atau tekan F4 atau juga dalam
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Toolbar pilih menu Export FLA.

m Expart FLA

Simbol Export SWF Ke FLA

= Maka akan muncul kotak dialog Save As.
= Dalam kotak dialog Save As Pilih Save untuk menyimpan File yang
sudah dijadikan FLA.

Save As
Save in; '_i ty Daocuments v « o+ % El'
B ‘ﬁMy Music
f) BMV Pictures

My Recent |Z)Updater
Documents

-

Desklop

My Documents

-
)
L
My Computer
‘-’] File narne: Tpacmat_egg [l
2
My Metwork.  Save as ype: Flash Documert % fla) ]

Tampilan Kotak Dilaog Save

4. Convert Format SWF ke FLA selesai.

2. Mengedit Tulisan dalam Format SWF Ke FLA

Dalam topik bahasan diatas diharapkan pembaca sudah dapat mengerti bagaimana
cara mengconvert Format SWF Ke FLA dengan meggunakan SWF Decompiler. Dan
sekarang kini kita akan latihan bagaimana cara mengedit suatu Format SWF yang
sudah di convert menjadi FLA.

Untuk pembahasan kali ini kita akan mengedit suatu tulisan yang ada di dalam
Format SWF yang sudah diconvert menjadi FLA.
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acromedia yer

eyou

File Miew Control Help

File Miew Control Debug

Sebelum di Edit Sesudah di Edit

1. Buka Aplikasi SWF Decompiler

2. Dalam File explorer Buka File Be You.SWF vyang disertakan didalam CD
latihan kedalam aplikasi SWF Decompiler

3. Convert menjadi Format FLA, dengan menekan Export FLA yang ada di
dalam Tool bar SWF Decompiler.

4. Simpan dengan File Name nya Be You FLA.

5. Buka Aplikasi Macromedia Flash 8

6. Tampilkan Be you fla yang sudah di convert melalui SWF Decompiler

7. Dalam jendela Timline pada Layer 11 ( yang mana Layer 11 adalah teks yang

kita edit ).

= pilih frame 123 dan blok hingga ke Frame 110.
= Kilik kanan pilih Clear Keyframe.

= 590 e 105 0 115 120 125 120 135
[ Seript 0 + + @

B Layer 13 R |
D T g [ Creake Motion Tween
ayer L

=
I Laver 11
=
B Laver 7 « + [ Insert Frame
| Remaove Frames
4 E] f || ¢ @lw w [

Insert Kevframe

Insert Blank Keyvframe
Corvett ko Kevframes
Conert bo Blank Kevframes

B

Tampilan Frame yang diblok
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8. Dalam Layer 11 pada Frame 110 tekan F6.

A
9. Masih dalam Layer 11 di frame 110 Pilih Teks Tool lalu buat teks
Jangan kehilangan dirimu dalam jendela Properties pilih opsi berikut :

= Font : Time New Rowman
= Size 17
= Style : Bold
= Align : Center
= TextFil : #1E79E7
10.Pilih teks Jangan kehilangan dirimu dengan menggunakan Selection Tool
e

, kemudian dalam Menu utama pilih Window > Align atau menekan
CTRL + K dalam kotak dialog Align Pilih Opsi :

i = Align & Info & Transform =
align 2|

align:

= |&)Sl B0 4 Oo /o,
DiskribEe: skage:
Z@)2 b wwl O
Match Se Space:

Sl 05 Be 2 4L

Gambar 1.7.
Tampilan Kotak Dialog Align

1. Dalam To Stage Pilih tombol Align/Distribute To Stage.

2. Dalam Align pilih tombol Align Horizontal Center

3. Dalam Distribute pilih tombol Distribute Vertical Center
11.Kemudian Pilih teks Jangan kehilangan dirimu dengan menggunakan

Selection Tool k lalu tekan F8, pilih Movie clip dan beri Nama edit_teks.
12. Dalam Layer 11 pada frame 123 tekan F6

13. Di Layer 11 antara frame 110 s/d 123 klik kanan pilih create motion tween

14.Klik frame 110 pilih teks Jangan kehilangan dirimu, dan di jendela properties
pada opsi Color pilih Alpha beri nilai O %6.

15. Masih pada Layer 11 pada frame 124 tekan F6

16. Tekan CTRL + Enter untuk melihat hasil movie nya.

3. Mengedit Gambar dalam Format SWF Ke FLA

Dalam pembahasan yang ke-dua, pembaca akan mendapat latihan bagaimana
mengedit suatu Gambar dalam Format SWF Ke FLA dengan menggunakan SWF
Decompiler. Dan dalam Latihan kali ini diharapkan pembaca sudah memahami
tentang bagaimana cara mengedit suatu Tulisan dalam Format SWF ke FLA dengan
menggunakan SWF Decompiler yang sudah dibahas diatas.

Berikut adalah contoh pengeditan gambar dalam Format SWF yang sudah diconvert
menjadi Format FLA.
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CINmE <] v Lo

File Wiew Contral File Miew Conkrol

Help Help

TN
<€

Sebelum di edit Sesudah di edit

1. Buka Aplikasi SWF Decompiler.

2. Dalam Explorer cari Format SWF yang ingin dijadikan Format FLA
( Pada Latihan kali ini kita menggunakan ngajari SWF yang disertakan dalam
CD latihan ).

3. Dalam menu utama pilih File > Export FLA atau tekan F4 atau bisa juga dengan
menekan Export FLA yang ada di dalam Tool bar SWF Decompiler.

ﬁ Export FLA

Simbol Export SWF Ke FLA

= Maka akan muncul kotak dialog Save As.

= Dalam kotak dialog Save As pilih Save untuk menyimpan File yang
sudah dijadikan FLA.

= Simpan File Anda

Save As
Save in |BMyDocuments [V] ) ? | '
: iy Mus
u:ﬁ hﬂmz Pi:tsLllcres

My Recent |5 Updater
Documents

T

o

@

i

o
=1
o

My Documents

@ w

My Computer

File name: | ~pacman_egg [V] [ Save ]

My NEt‘Wle Save a3 type: | Flash Documert [*.fla) [v] [ Cancel ]

Tampilan Kotak dialog Save

4. Convert Fomat SWF ke FLA selesai.
5. Buka Aplikasi Macromedia Flash 8
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Tampilkan ngajari FLA yang sudah di convert melalui SWF Decompiler
Dalam Jendela Timeline pada Layer 1 di Frame 1 Delete gambar ngajari.
Pada menu File pilih Import = Import To Library
= Pada kota dialog Import To Library cari gambar Mata yang
disertakan dalam CD.
= Pilih Open untuk membuka nya di aplikasi Macromedia Flash
= Tekan F11 atau pilih menu Window > Library untuk menampilkan
gambar Mata
= Drag gambar mata kedalam layar kanvas
9. Kemudian tekan CTRL + K atau pilih menu Window > Align.
1) Dalam kotak dialog Align pilih To Stage
2) Pada Align pilih tombol Align Left Edge.
3) Kemudian pada Distribute pilih Distribute Top Edge.

o N

X
i = align & Info & Transform =
Align fo | Transform
¢ 1
Sl T e Do/,
stage:
= b 0Edy O
: : Space:
S B =2 db

Kotak Dialog Align

10. Pengeditan telah selesai untuk melihat Movie nya tekan tombol CTRL + Enter.
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